So I recently did something I swore I would never do… I finally got on board with Telstra, for internet access. I’ve had a mobile service with Telstra for nearly 20 years, but I’ve always used a separate carrier for my internet access. This week, that changed.

When the Telstra Smart Modem (with 4G) arrived, as per the order and the propaganda, I expected to be able to fire that bad boy up and get internet access straight away via 4G, while I waited a few days for my ADSL to be connected. Nope.

Firstly, my Smart Modem wasn’t even configured with my ADSL/NBN credentials, of which I didn’t even know until after the ADSL had been connected. Note: The Smart Modem refers to all connectivity now as ‘Broadband’. Don’t be worried if you don’t see ‘ADSL’ or ‘NBN’ anywhere as we progress further. In fact, wherever I say ‘ADSL’ or ‘NBN’ think ‘Broadband’.

For anyone wondering, your ADSL/NBN credentials are the username sent to you and password you set, previous to the Smart Modem being delivered. I found my username in an email (it was a typical @bigpond.com username with an annoying number in it) and there was a link to follow to set my password (you can choose to have it emailed to you or sent to your mobile as an SMS). I nearly missed the email because it just looked like another piece of Telstra propaganda marketing. If you think you should have yours by now, go check your email, all of them (from Telstra), carefully. Don’t forget to check your Junk Mail or Spam if you can’t see it anywhere else!

If you want to know if the credentials you have are correct, click here: https://www.my.telstra.com.au/myaccount/home and see if you can login with them. Don’t worry about what you do or do not see once you are logged in. So long as you can login successfully, the credentials you have are correct.

You can configure the ADSL/NBN credentials by logging into the Smart Modem from a browser using the Smart Modem’s IP Address (obviously you’ll need to be connected to the Smart Modem’s Wi-Fi or via a network cable). For me, that IP Address was: 192.168.0.1. Unless you have already set a new admin password, by default, you can configure the whole device without any further credentials. In other words, if you’re doing this for the first time, it won’t ask you for an ‘admin’ password. In your browser, enter: http://192.168.0.1.

To configure your ADSL/NBN credentials, once logged into the Smart Modem, go to the Broadband page and under the PPPoE Settings heading, enter your username and password. In my case, this was the username and password I configured previous to receiving my Smart Modem (see above), which, until now, I thought was just my Telstra billing account. It actually turned out that they attached my new internet service to my existing Telstra mobile account. How convenient! It would have also been nice to have been told that. This explains why when I logged into the Telstra portal (see link above) with my ADSL/NBN credentials, I didn’t see anything attached to my account (like an internet service)…. I digress.

With the ADSL/NBN credentials configured, the ADSL service (later it will be NBN when it’s provisioned in my area) came to life and internet access was up and running. Obviously, if you’ve purchased an NBN service instead, your NBN service will now be up. FYI: Unless you have a fibre to the home (FTTH) service, your NBN service will more than likely use your telephone line. Don’t worry, you haven’t been duped, it’s not super fast ADSL, it just uses the same cables/wires in the ground.

Now, 4G access. Physically disconnect the ADSL/NBN and the 4G service should kick in right? Nope.

In fact, when I logged into the Smart Modem and had a look at the ‘Advanced’ –> Mobile settings, it looked like the 4G service didn’t work. I actually suspected my Smart Modem was faulty. Turns out it wasn’t. Firstly, to view the Mobile settings, as explained above, login to the Smart Modem. By default, you’re in ‘Basic’ view. On the right hand side at the top, there’s an icon (a spanner and a screw driver) called Advanced. Click it. Now you’ll see an arrangement of boxes for the many features of the Smart Modem. We’re interested in Mobile.

OK, this is where it gets a little tricky. If you’ve had your Smart Modem switched on for a while, like me, you’ll see a message to the effect of: No Device detected (or No Device connected). I actually considered the possibility that I was supposed to have a 4G dongle attached (there is a USB port) or that maybe the SIM card was faulty or not activated and so on. To resolve this, you can do one of potentially two or more things (depending on how creative you are). You can keep refreshing the ‘Advanced’ view until the Mobile box shows a message to the effect of: Configuring Device (or Connecting), or you can just restart the Smart Modem with the ADSL/NBN physically disconnected. Once you’re able to get the ‘Advanced’ view, Mobile showing a message to the effect of: Configuring Device (or something similar), click Mobile.

You’ll need to work kind of quickly (don’t panic though, you can always try this more than once), as eventually the Smart Modem does give up trying to connect the 4G service if it fails too many times. When this happens, all of the options under Mobile are hidden and a message (red text on a red background) is displayed indicating the device is not connected.

You’ll now be on the Configuration tab. You can actually see a message in the middle of the screen (orange text on yellow background…) to the effect of: You must select the telstra.hybrid profile for your backup service to work. Just like me, you’ll be thinking “that’s already selected!”, as you can see that it is selected, directly below that message! Don’t worry about the SIM and Diagnostics tabs for now. Click the Profiles tab. Click the [Add new profile] button.

In the Name field, enter telstra.hybrid2 (it can be anything really). In the APN field, you must enter telstra.hybrid. In the PDP Type field, select IPv4v6. In the Username field, enter your ADSL/NBN username. In the Password field, enter your ADSL/NBN password.  In the Authentication Type field, select None. Click the [Add]/[+] button and then click the [Close] button. Click Mobile again. On the Configuration tab, click the edit icon (it looks like a little pencil on a notepad) under the Interfaces heading (its kind of in the middle of the screen, to the right). You’ll see the Linked Profile field becomes a selection list. Click it and select telstra.hybrid2 (or whatever you named it above). Click the [Tick] button (it’s an icon that looks like a check mark) and then click the [Close] button.

Wait 1-5 minutes (no longer, really) and you should see your Mobile service come to life. You’ll know, as you’ll be able to access the internet 😉 also, in the ‘Advanced’ view, Mobile, you’ll see messages to the effect of: Status: Connected, Radio Type: LTE and Quality: Good. Now is a good time to go back and take a look at the SIM and Diagnostics tabs if you’re so inclined. There’s nothing to do or configure. They are just informational. If something was to ever happen to the SIM card, it could be useful to have the ICCID and the IMSI recorded somewhere. Up to you.

We’re almost done. The profile you created above, isn’t actually necessary. Apart from calling it telstra.hybrid2 (or whatever you called it) it’s identical to the existing telstra.hybrid (without the username and password, also not needed) Using the same steps, let’s switch the Mobile configuration back to the telstra.hybrid profile.

In the ‘Advanced’ view, click Mobile. On the Configuration tab, click the edit icon (it looks like a little pencil on a notepad) under the Interfaces heading (its kind of in the middle of the screen, to the right). You’ll see the Linked Profile field becomes a selection list. Click it and select telstra.hybrid. Click the [Tick] button (it’s an icon that looks like a check mark) and then click the [Close] button.

Wait 1-5 minutes (no longer, really) and you should see your Mobile service come back to life. You’ll know, as you’ll be able to access the internet again 😉 also, in the ‘Advanced’ view, Mobile, you’ll see messages to the effect of: Status: Connected, Radio Type: LTE and Quality: Good.

Last but not least, the profile you created, can now be deleted. In the ‘Advanced’ view, click Mobile. Click the Profiles tab. To the right of the profile you created previously, you’ll see an [Edit] button and a [Delete]/[X] button. Click the [Delete]/[X] button. Click the [Close] button.

That’s it, you’re done! Obviously, this is a bug/glitch in the matrix in the Smart Modem software, as simply switching the profile between telstra.hybrid and telstra.internet, you would think, would work / have the same effect, saving you from creating the additional profile. It doesn’t. For some reason, creating another identical profile and switching between it and the profile you need to use, does the trick. Let’s not forget the fact that it should have just worked out of the box and I shouldn’t have had to try all kinds of trickery to get it working…

P.S. This could have been one of those ‘techie aura’ moments, as I was on the phone to Telstra (in the queue and only just answered by a representative) when I tried the above steps and it came to life. The Telstra representative did not tell me to do any of the above. In fact, they advised me not to use the 4G internet except for when the ADSL/NBN is truly down, as the ADSL/NBN will be “faster” then the 4G internet. In my case (ADSL), the 4G internet is faster 😉

Leave a Reply

Post Navigation