Over the past three weeks, I have spent considerable time trying to get Apple’s latest Mac OS X offering (Mavericks) working on non-apple hardware. Mainly because Apple had released it for free (are you coming to the show, Microsoft?) and my old Snow Leopard OS X computer was starting to get… well, long in the tooth 😉

As I said, three weeks. Obviously I wasn’t working on it for three weeks night and day, but I did spend a fair amount of time to get to the configuration I am using to write this very post. Not much of this post actually pertains to the fact that I installed Mac OS X Mavericks on a Toshiba Laptop, it’s more that I couldn’t find many posts that mentioned any type of PC or laptop, so I figured there had to be others like me out there, possibly with a Toshiba laptop, trying to install Mac OS X Mavericks on it.

Warning!

The following is my journey. It comes with absolutely no warranty of any kind and I do not accept any responsibility at all, regardless of you following my instructions to the letter or not, if this results negatively for you in some way. Back up all data and proceed at your own risk.

Installation Media

To get the installation media from Apple, you need an existing Mac with at least Mac OS X 10.6 and AppStore installed. My 10.3 SL, was not going to cut it. Why couldn’t I update? My 10.3 SL machine, has an Intel atom processor that is no longer supported in newer releases of Mac OS X. I tried anyway, it failed. Thankfully, I was able to restore from a Time Machine backup. Use Time Machine! It’s awesome!

I ended up a little off course, but to get Apple OS X Mavericks, I downloaded a VMWare Virtual Machine image with Mac OS X Mavericks already installed. Your adventure with VMWare Workstation and OSX Mavericks, starts here: http://www.souldevteam.net/blog/2013/10/06/os-x-mavericks-10-9-retail-vmware-image-release-notes-links/. There is a video on the blog post, Watch It And Pay Attention!

You will also need VMWare Workstation. The 30 day trial is completely unrestricted and works perfectly fine. I am running VMWare Workstation 10.0.1 at the time of writing. You’ll see in the video (and downloaded files) that earlier versions of VMWare Workstation are also supported. Your adventure with VMWare Workstation, starts here: https://my.vmware.com/web/vmware/info/slug/desktop_end_user_computing/vmware_workstation/10_0.

Note: You must use VMWare Workstation for Windows, on Windows. VMware Workstation will need to be patched (unlocked), to be able to run Mac OS X Mavericks. The patch that accompanies the VMWare Workstation image is designed for Windows, not for Linux. Sorry, Linux users. If you’re clever enough, you might be able to get it to work on Linux. I haven’t look into this at all. Let me know if you are successful.

Once you have VMWare Workstation installed with your Mac OS X Mavericks virtual machine running, use the AppStore to download Mac OS X Mavericks 10.9, for free!

Of course, if  you have access to an actual Mac or a Hackintosh with Mac OS X 10.6 or higher, you are home free. Install the AppStore if you haven’t done so already and download Mac OS X Mavericks, for free!

Note: To download Mac OS X Mavericks, you will need to be signed into an Apple account. Just an FYI. It’s no big deal. An account is free and you don’t need to have a credit card or any payment options set up to download Mac OS X Mavericks. It’s free, really!

Once you have Mac OS X Mavericks downloaded, don’t install it. It looks like an App, and may try to install itself (even though you may be on Mac OS X Mavericks already). If it does, just cancel the install.

Read More →

A little while ago I purchased a Nokia Lumia 920 with Windows Phone 8 (currently the Amber release). The phone itself is great, but I had a problem with the Windows Phone WordPress app, it wouldn’t upload or post any content that contained an image.

  • Phone: Nokia Lumia 920
  • OS: Windows Phone 8 (amber – Australia)
  • Connectivity: WiFi and 3G/4G
  • Problem: WordPress App won’t complete submission of a post or page that contains an image.
  • Server: Xen VDS hosted on Amazon AWS with Amazon Linux (Amazon’s version of CentOS 6)

In case it’s not obvious, the WordPress blog I was experiencing the problem with is a self hosted installation. We can assume I installed it and set it up correctly 😉

(for sake of this post, I have replaced all references to the host with ‘mokonamodoki.com’).

Whenever I attempted to submit a page or post that contained an image, I would get the follow error message:

Media Upload Error

The remote server returned an error: NotFound

Yes, extremely helpful. I knew what the solution was immediately. Thank you, Microsoft!

I tried all sorts of tricks. PHP settings,  Apache settings, and WordPress settings. Nothing worked. What frustrated me even more; was that the iOS app worked fine! Something I did notice, was that the iOS app uploads images separately, and not as part of the post content… this got me thinking.

Is the problem the Windows Phone WordPress app or is the problem the server?

Read More →